您的位置:首页 > 移动开发

POJ 2387 第一道Dijkstra AC的很纠结

2010-12-06 22:27 302 查看
 

Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13050 Accepted: 4261
Description
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90

无向图的最短路径,求1到N的最短路径

#include<stdio.h>
#define MAX 1000008
#define bool _Bool
#define true 1
#define false 0
int t,n;
int arc[1001][1001];
int dist[1001];
bool visited[1001];
void dijkstra(int src)
{
int _i,_j,_k,tmp,pos;
for(_i=1;_i<=n;_i++)
dist[_i]=arc[src][_i],visited[_i]=false;
visited[src]=true;
dist[src]=0;
for(_i=1;_i<n;_i++)
{
tmp=MAX;
pos=src;
for(_j=1;_j<=n;_j++)
if((!visited[_j])&&(dist[_j]<tmp))
{
pos=_j;
tmp=dist[_j];
}
visited[pos]=true;
for(_j=1;_j<=n;_j++)
if((!visited[_j])&&(dist[pos]+arc[pos][_j]<dist[_j]))
dist[_j]=dist[pos]+arc[pos][_j];
}
}
int main()
{
int i,j;
int x,y,len;
freopen("input","r",stdin);
scanf("%d %d",&t,&n);
memset(arc,MAX,sizeof(arc));
for(i=0;i<t;i++)
{
scanf("%d %d %d",&x,&y,&len);
if(arc[x][y]>len)
{
arc[x][y]=len;
arc[y][x]=len;
}
}
dijkstra(1);
printf("%d/n",dist
);
return 0;
}
 
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息