您的位置:首页 > 其它

A + B Problem II

2010-11-24 17:15 99 查看
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211


Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


答案:

#include <stdio.h>
#include <string>

int main(int argc, char* argv[])
{
int n, i;
scanf("%d", &n);

char** a = new char*
;
char** b = new char*
;
char** r = new char*
;

for (i = 0; i < n; ++i)
{
a[i] = new char [1000];
b[i] = new char [1000];
r[i] = new char [1000];
memset(r[i], 0 , sizeof(char)*1000);
}

for (i = 0; i < n; ++i)
{
scanf("%s", a[i]);
scanf("%s", b[i]);
}

for (i = 0; i < n; ++i)
{
printf("Case %d:/n", i+1);
int aSize = strlen(a[i]);
int bSize = strlen(b[i]);
int k = 0, v = 0, u = 0, j;
while (true)
{
if (aSize <= 0 && bSize <= 0)
{
if (u>0)
r[i][k++] = u+'0';
break;
}
else if (aSize <= 0)
{
v = b[i][bSize-1]-'0'+u;
u = v>9?v/10:0;
v = v>9?v%10:v;
r[i][k++] = v+'0';
--bSize;
}
else if (bSize <= 0)
{
v = a[i][aSize-1]-'0'+u;
u = v>9?v/10:0;
v = v>9?v%10:v;
r[i][k++] = v+'0';
--aSize;
}
else
{
v = a[i][aSize-1]-'0'+b[i][bSize-1]-'0'+u;
u = v>9?v/10:0;
v = v>9?v%10:v;
r[i][k++] = v+'0';
--aSize;
--bSize;
}
}
for (j = 0; j < k/2; ++j)
{
char tmp = r[i][j];
r[i][j] = r[i][k-j-1];
r[i][k-j-1] = tmp;
}

if (i == n-1)
printf("%s + %s = %s/n", a[i], b[i], r[i]);
else
printf("%s + %s = %s/n/n", a[i], b[i], r[i]);
}

delete [] a;
delete [] b;
delete [] r;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: