您的位置:首页 > 其它

POJ 1562 DFS水题练习

2010-11-19 08:45 253 查看
Oil Deposits

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 6282Accepted: 3557
Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

#include<stdio.h>
#include<stdlib.h>

int m,n;
char grid[102][102];

void DFS(int a,int b)
{
if(grid[a][b]=='*'||a<0||b<0||a>m-1||b>n-1) return;
grid[a][b]='*';
//printf("访问grid[%d][%d]/n",a,b);
DFS(a,b+1);
DFS(a,b-1);
DFS(a-1,b-1);
DFS(a-1,b+1);
DFS(a-1,b);
DFS(a+1,b-1);
DFS(a+1,b);
DFS(a+1,b+1);

}
int main()
{
int i,j;
int cnt;
while(scanf("%d %d",&m,&n)!=EOF&&m!=0)
{
cnt=0;
memset(grid,0,sizeof(grid));
for(i=0;i<m;i++)
scanf("%s",grid[i]);
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(grid[i][j]=='@')
{
cnt++;
DFS(i,j);
}
}
printf("%d/n",cnt);
}
return 0;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: