您的位置:首页 > 编程语言 > PHP开发

joj1349 Oil Deposits

2010-11-18 12:10 302 查看



1349
: Oil Deposits

ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE


3s8192K533260Standard
The GeoSurvComp geologic survey company is responsible for detecting
underground oil deposits. GeoSurvComp works with one large rectangular
region of land at a time, and creates
a grid that divides the land into numerous square plots. It then analyzes
each plot separately,
using sensing equipment to determine whether or not the plot contains oil.

A plot containing
oil is called a pocket. If two pockets are adjacent, then they are part of
the same oil deposit. Oil
deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line
containing m
and n
, the
number of rows and columns in the grid, separated by a single space. If
m
= 0 it signals the end
of the input; otherwise



and



.
Following
this are m
lines of n
characters
each (not counting the end-of-line characters). Each character corresponds to
one plot, and is
either `*
', representing the absence of oil, or `@
', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different
pockets are part of the
same oil deposit if they are adjacent horizontally, vertically, or diagonally.
An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

基本的深搜,回溯法找联通块

#include<iostream>

#include<cstring>

using namespace std;

char map[105][105];

int vis[105][105];

int m,n,count1;

void dfs(int x,int y)

{

if(x>=1&&x<=m&&y>=1&&y<=n)

{

if(map[x][y]=='*'||vis[x][y]) return;

vis[x][y]=1;

dfs(x-1,y-1); dfs(x-1,y);dfs(x-1,y+1);

dfs(x,y-1);             dfs(x,y+1);

dfs(x+1,y-1); dfs(x+1,y);dfs(x+1,y+1);

}

else return;

}

int main()

{

while(cin>>m>>n)

{

if(m==0&&n==0) break;

count1=0;

memset(vis,0,sizeof(vis));

for(int i=1;i<=m;i++)

for(int j=1;j<=n;j++)

cin>>map[i][j];

for(int i=1;i<=m;i++)

for(int j=1;j<=n;j++)

if(!vis[i][j]&& map[i][j]=='@') {count1++;dfs(i,j);}

cout<<count1<<endl;

}

return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息