您的位置:首页 > 大数据 > 人工智能

acm pku 1218 The drunk jailer的算法分析与实现

2010-11-13 23:35 981 查看
THE DRUNK JAILER
Description
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He
repeats this for n rounds, takes a final drink, and passes out.
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.
Given the number of cells, determine how many prisoners escape jail.
Input
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.
Output
For each line, you must print out the number of prisoners that escape when the prison has n cells.
Sample Input
2
5
100
Sample Output
2
10
Source
Greater New York 2002

分析:对于有n个房间的监狱,狱卒进行n次关门,锁门操作。按照规矩,对第i个房间,若对狱卒的第k次操作,有i%k==0,则,进行一次锁/开门操作(若锁着则打开,若开着则锁上),若最后第i个房间被操作了奇数次,则该房间的囚犯可以逃出。

实现代码:
#include <string.h>
#include "iostream"
using namespace std;

int EscapeNum(int n)
{
int sum = 0;
int i, j;
int escape[101];

memset(escape, 0, sizeof(int)*101);
for(i = 1; i <= n; i++)
{
for(j = 1; j <= n; j++)
{
if(i%j == 0)
escape[i]++ ;
}
}

for(i = 1; i <= n; i++)
{
if(escape[i]%2 == 1)
sum++ ;
}
return sum;
}

int main(void)
{
int in, n;

cin >> in;
while(in > 0)
{
cin >> n;
cout << EscapeNum(n) << endl;
in-- ;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: