您的位置:首页 > 其它

2506 Tiling 递推 大数

2010-11-11 15:36 375 查看
Tiling

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5316Accepted: 2583
Description
In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.



Input
Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.
Output
For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input
2
8
12
100
200

Sample Output
3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

/*
* To change this template, choose Tools | Templates
* and open the template in the editor.
*/

/**
*
* @author Administrator
*/
import java.util.*;
import java.math.*;
public class Main {

/**
* @param args the command line arguments
*/
public static void main(String[] args) {
// TODO code application logic here
Scanner cin=new Scanner(System.in);
int n;
BigInteger []f=new BigInteger[301];
f[0]=BigInteger.valueOf(1);
f[1]=BigInteger.valueOf(1);
f[2]=BigInteger.valueOf(3);
for(int i=3;i<300;i++)
{
f[i]=f[i-1].add(f[i-2].multiply(BigInteger.valueOf(2)));
}
while(cin.hasNext())
{
n=cin.nextInt();
System.out.println(f
);
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: