您的位置:首页 > 其它

【原】 POJ 3087 Shuffle'm Up 模拟题 解题报告

2010-11-08 19:35 477 查看
 

http://poj.org/problem?id=3087

 

简单的模拟题,模拟洗牌

 

Description

A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:





The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom ofS1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output

Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input

2

4

AHAH

HAHA

HHAAAAHH

3

CDE

CDE

EEDDCC

Sample Output

1 2

2 –1

 

[code]     [code] #include <stdio.h>


#include <iostream>


#include <string>


 


using namespace std ;


 


void run3087()


{


int n,m,i ;


int cnt ;


int len,bottom1,bottomResult ;


string s1,s2,result ;


string tmp1,tmp2,tmpResult ;


 


scanf( "%d", &n ) ;


for( i=1 ; i<=n ; ++i )


    {


scanf( "%d", &m ) ;


cin>>s1>>s2>>result ;


len = s1.size() ;


 


cnt = 0 ;


tmp1 = s1 ;


tmp2 = s2 ;


tmpResult = result ;


while( true )


   {


//shuffle


bottom1=bottomResult=0 ;


while( bottom1<len )


       {


tmpResult[bottomResult++] = tmp2[bottom1] ;


tmpResult[bottomResult++] = tmp1[bottom1++] ;


}


++cnt ;


 


if( tmpResult == result )


       {


printf("%d %d\n", i,cnt) ;


break ;


}


 


//break


//get new s1 and s2


bottom1=bottomResult=0 ;


while( bottom1<len )


tmp1[bottom1++] = tmpResult[bottomResult++] ;


bottom1 = 0 ;


while( bottom1<len )


tmp2[bottom1++] = tmpResult[bottomResult++] ;


 


//当又回到原来初始牌的状态时,则表明形成循环且无解


if( tmp1 == s1 )


       {


printf("%d -1\n", i) ;


break ;


}


}


}


}

[/code]
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: