您的位置:首页 > 其它

Second My Problem First HDOJ 5th Anniversary Contest 1007

2010-10-31 15:49 387 查看

Second My Problem First

Time Limit: 12000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1272 Accepted Submission(s): 212


Problem Description
Give you three integers n, A and B.
Then we define Si = Ai mod B and Ti = Min{ Sk | i-A <= k <= i, k >= 1}
Your task is to calculate the product of Ti (1 <= i <= n) mod B.



Input
Each line will contain three integers n(1 <= n <= 107),A and B(1 <= A, B <= 231-1).
Process to end of file.



Output
For each case, output the answer in a single line.



Sample Input

1 2 3
2 3 4
3 4 5
4 5 6
5 6 7





Sample Output

2
3
4
5
6





Author
WhereIsHeroFrom@HDU
相似题目:pku Sliding window
单调队列处理查询是递增的区间最小值

#include<iostream>
using namespace std;
#define N 10000000
int n;
struct QU
{
int pos;
__int64 value;
}Q[N];

int main()
{
__int64 a,b,t,i,ans,minn,ss;
while(scanf("%I64d%I64d%I64d",&n,&a,&b)!=EOF)
{
int head=1;
int tail=0;
t=a;
ans=1;
minn=a;
for(i=1;i<=n&&a!=1;i++)
{
ss=a%b;
while(head<=tail&&ss<Q[tail].value)
tail--;
while(head<=tail&&Q[head].pos<i-t)
head++;
Q[++tail].value=ss;
Q[tail].pos=i;
ans=(ans*Q[head].value)%b;

a=(a*t)%b;
}
printf("%I64d/n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: