您的位置:首页 > 大数据 > 人工智能

hdu 3496 Watch The Movie //2010 ACM-ICPC Multi-University Training Contest(6)——Host by BIT

2010-10-07 19:45 549 查看

Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 864    Accepted Submission(s): 307


Problem Description
New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.
DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.
But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they cost not more then L.
How clever you are! Please help DuoDuo’s uncle.
 
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:
The first line is: N(N <= 100),M(M<=N),L(L <= 1000)
N: the number of DVD that DuoDuo want buy. 
M: the number of DVD that the shop can sale.
L: the longest time that her grandfather allowed to watch.
The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 
 

Output
Contain one number. (It is less then 2^31.)
The total value that DuoDuo can get tonight.
If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 
 

Sample Input

1
3 2 10
11 100
1 2
9 1

 
 

Sample Output

3

 
 

Source
2010 ACM-ICPC Multi-University Training Contest(6)——Host by BIT
 
 

Recommend
zhouzeyong
一道很明显的背包,就是0,1背包的变形,不过加入了一个限制,就是必须要拿M个,如果在时间的限制下拿不了M个,那么就输出0
所以要给转移方程增加一个状态,即已经拿了的数目和价值
dp[i][j]=max{dp[i][j],dp[i-1][j-cost[k]]+val[K]}
WA了几次,是在初始化上。。。。
背包九讲有提到:
如果是要求背包恰好装满的最大值,那么初始化除了dp[0][0]=0,其他都为-inf
如果没必要吧背包装满,而只要求价值最大,那么直接初始化为0就可以了。
初始化的合法性:
1.求背包恰好装满的最大值,只有dp[0][0]=0有合法性,其他用nothing表示了
2.求背包最大值,每个状态都可不装,都合法。
#include<cstdio>
#include<cstring>
#define max(a,b)  a>b?a:b
#define min(a,b)  a>b?b:a
const int inf=1<<28-1;
int t[110],v[110];
int f[101][1001];
int main()
{
int T;
int n,m,l;
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&m,&l);
for(int i=0;i<=m;i++)
for(int j=0;j<=l;j++)
f[i][j]=-inf;
f[0][0]=0;
for(int i=1;i<=n;i++)  scanf("%d%d",&t[i],&v[i]);
for(int i=1;i<=n;i++)
{
int tt=min(i,m);
for(int j=tt;j>=1;j--)
for(int k=l;k>=t[i];k--)
f[j][k]=max(f[j-1][k-t[i]]+v[i],f[j][k]);
}
int rmax=-1;
for(int i=1;i<=l;i++)
if(f[m][i]>rmax)  rmax=f[m][i];
if(rmax!=-1) printf("%d/n",rmax);
else printf("0/n");
}
return 0;
}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
相关文章推荐