您的位置:首页 > 其它

pku1330 LCA问题

2010-09-23 20:11 363 查看
Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:

In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2

16

1 14

8 5

10 16

5 9

4 6

8 4

4 10

1 13

6 15

10 11

6 7

10 2

16 3

8 1

16 12

16 7

5

2 3

3 4

3 1

1 5

3 5

Sample Output

4

3

Source

Taejon 2002

解:
利用DFS及Disjoint-set forest来实现
首先看看Disjoint-set forest



图1. Disjoint-set forests
When we use both union by rank and path compression, the worst-case running time is O(m α (n)), where α(n) is a very slowly growing function, which we define in Section 21.4. In any conceivable application of a disjoint-set data structure, α(n) ≤ 4; thus, we can view the running time as linear in m in all practical situations. In Section 21.4, we prove this upper bound.

源码
]#include <iostream>
#include <vector>
#include <cassert>
#include <iomanip>
using namespace std;
//#define DEBUG
class Node
{
public:
vector<int> child;
vector<int> query;
int p;
int rank;
int ancestor;
int degree;
bool finished;
};
class Tree
{
private:
static const int MAX_NODES = 10001;
int nb_node;
Node node[MAX_NODES];
private:
void init();
void do_lca(const int u);
inline void make_set(const int u);
int find_set(const int u);
inline void union_set(const int u, const int v);
void internal_link(const int u, const int v);
public:
Tree(): nb_node(0){};
void construct_tree();
void lca();
#ifdef DEBUG
void print_tree()const;
#endif
};
#ifdef DEBUG
void Tree::print_tree()const
{
for (int i = 1; i < nb_node; i++){
cout << i << ": ";
for (vector<int>::const_iterator it = node[i].child.begin();
it != node[i].child.end(); it++){
cout << setw(5) << *it;
}
cout << endl;
}
}
#endif
void Tree::init()
{
for (int u = 1; u <= nb_node; u++){
node[u].child.clear();
node[u].query.clear();
node[u].p = 0;
node[u].rank = 0;
node[u].ancestor = 0;
node[u].degree = 0;
node[u].finished = false;
}
}
void Tree::construct_tree()
{
int u, v;
cin >> nb_node;
init();
for (int j = 0; j < nb_node - 1; j++){
cin >> u >> v; /*arc*/
node[u].child.push_back(v);
node[v].degree++;
}
cin >> u >> v; /*query*/
node[u].query.push_back(v);
node[v].query.push_back(u);
}
void Tree::make_set(const int u)
{
node[u].p = u;
node[u].rank = 0;
}
int Tree::find_set(const int u)
{
if (u != node[u].p){
node[u].p = find_set(node[u].p);
}
return node[u].p;
}
void Tree::union_set(const int u, const int v)
{
internal_link(find_set(u), find_set(v));
}
void Tree::internal_link(const int u, const int v)
{
if (node[u].rank < node[v].rank){
node[u].p = v;
}else{
node[v].p = u;
if (node[u].rank == node[v].rank){
node[u].rank++;
}
}
}
void Tree::do_lca(const int u)
{
make_set(u);
node[u].ancestor = u;
for (vector<int>::iterator it = node[u].child.begin();
it != node[u].child.end(); it++){
do_lca(*it);
union_set(u, *it);
node[find_set(*it)].ancestor = u;
}
node[u].finished = true;
for (vector<int>::iterator it = node[u].query.begin();
it != node[u].query.end(); it++){
if (node[*it].finished){
cout << node[find_set(*it)].ancestor << endl;
}
}
}
void Tree::lca()
{
for (int i = 1; i < nb_node; i++){
if (0 == node[i].degree){
do_lca(i);
}
}
}
int main()
{
Tree tree;
int nb_t;
cin >> nb_t;
for (int i = 0; i < nb_t; i++){
tree.construct_tree();
#ifdef DEBUG
tree.print_tree();
#endif
tree.lca();
}
return 0;
}


算法伪码如下:
]LCA(u)
//color[u] <- gray
//d[u] <- time <- time + 1
MAKE-SET(u)
accestor[u] <- u
for each v in Adj[u]
do //if color[v] = WHITE
// then pi[v] <- u
LCA(v)
UNION(u, v)
accestor[FIND-SET(v)] <- u
//color[u] <- BLACK
f[u] <- time <- time + 1
for each (u, v) in QUERIES
do if f[v] > 0
then print ancestor[FIND-SET(v)]

分析



图2. LCA Tarjan算法示意
伪码注释部分为DFS的针对LCA问题可以省略的部分
当进入算法的13行,已经完成了节点u的DFS过程,这时以u为根的子树构成的disjoint-set在一个集合中(如图2所示),又根据DFS的过程,p(u)及u的左兄弟节点子树在一个集合中(如图2所示),如果查询(u, v)的v在这两个集合中,这时就可以得到查询结果了,分两种情况,如下。(如果v不在这两个集合中,则在完成v为根的子树的DFS时,u必定在这两个集合中,因为对于u,v在DFS的过程中总会有一个后完成DFS而前一个早已经完成DFS了)。
(1)如果v在p(u)及u的左兄弟节点子树在一个集合中(图2中v1),则该集合(代表元素)的ancesstor为p(u)(算法11行),很显然的p(u)就是查询(u, v)的所要的结果。
(2)如果v在以u为根的子树构成的disjoint-set在一个集合中(图2中v2),则该集合(代表元素)的ancesstor为u(算法11行),u就是查询(u, v)的结果。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: