您的位置:首页 > 其它

(优化的有限背包) poj 1742 Coins

2010-09-16 10:16 169 查看
Coins

Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 16723Accepted: 5807
Description
People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output
8
4
/*
题目大意:略;
题目解答:用化成2^k的方法复杂度为O(V*Σlog n[i]),优化后复杂度为o(NV);
ps:楼天成出的题目
Source Code

Problem: 1742  User: wawadimu
Memory: 920K  Time: 1313MS
Language: C++  Result: Accepted

Source Code
*/
#include<iostream>
#include<string>
using namespace std;
int dp[100001];
int A[101];//物品重量
int C[101];//物品数目
int num[100001];//当前使用第i种物品的数目
int n,m;
int main()
{
int i,j,sum;
while(scanf("%d%d",&n,&m)!=EOF && !(n==0 && m==0))
{
sum=0;
for(i=1;i<=n;i++)
scanf("%d",A+i);
for(i=1;i<=n;i++)
scanf("%d",C+i);
memset(dp,0,sizeof(dp));
dp[0]=1;//背包为空
for(i=1;i<=n;i++)
{
memset(num,0,sizeof(num));
for(j=A[i];j<=m;j++)//多重背包正序计算
{
if(!dp[j] && dp[j-A[i]] && num[j-A[i]] < C[i])//可添加第i种物品,并且没有超出数目限制
{
dp[j]=1;
sum++;
num[j]=num[j-A[i]]+1;//数目增加1
}
}
}
printf("%d/n",sum);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: