您的位置:首页 > 其它

(最大流) poj 1459 Power Network

2010-09-15 22:09 423 查看
Power Network

Time Limit:
2000MS
Memory Limit:
32768K
Total Submissions:
11326
Accepted:
6220
Description
A
power network consists of nodes (power stations, consumers and
dispatchers) connected by power transport lines. A node u may be
supplied with an amount s(u) >= 0 of power, may produce an amount 0
<= p(u) <= pmax
(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax
(u))
of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The
following restrictions apply: c(u)=0 for any power station, p(u)=0 for
any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one
power transport line (u,v) from a node u to a node v in the net; it
transports an amount 0 <= l(u,v) <= lmax
(u,v) of power delivered by u to v. Let Con=Σu
c(u) be the power consumed in the net. The problem is to compute the maximum value of Con.



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax
(u)=y. The label x/y of consumer u shows that c(u)=x and cmax
(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax
(u,v)=y.
The power consumed is Con=6. Notice that there are other possible
states of the network but the value of Con cannot exceed 6.

Input
There
are several data sets in the input. Each data set encodes a power
network. It starts with four integers: 0 <= n <= 100 (nodes), 0
<= np <= n (power stations), 0 <= nc <= n (consumers), and 0
<= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <=
z <= 1000 is the value of lmax
(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax
(u).
The data set ends with nc doublets (u)z, where u is the identifier of a
consumer and 0 <= z <= 10000 is the value of cmax
(u).
All input numbers are integers. Except the (u,v)z triplets and the (u)z
doublets, which do not contain white spaces, white spaces can occur
freely in input. Input data terminate with an end of file and are
correct.
Output
For
each data set from the input, the program prints on the standard output
the maximum amount of power that can be consumed in the corresponding
network. Each result has an integral value and is printed from the
beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20

7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7

(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5

(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15

6

/*
题目大意:有n个顶点,np个发电站,nc个用户,求最大传输电量
题目解答:典型多源多汇点的最大流问题
Source Code

Problem: 1459  User: wawadimu
Memory: 232K  Time: 516MS
Language: C++  Result: Accepted

Source Code
*/
#include<iostream>
#include<queue>
using namespace std;

#define maxn 110
#define inf INT_MAX
int n,np,nc,m;
int flow[maxn][maxn],cap[maxn][maxn];
int a[maxn],p[maxn];

int maxflow(int s,int t)
{
memset(flow,0,sizeof(flow));
int max=0;
int u,v;
while(1)
{
memset(a,0,sizeof(a));
queue<int> q;
q.push(s);
a[s]=inf;
while(!q.empty())
{
u=q.front();q.pop();
for(v=0;v<=t;v++)
{
if(!a[v] && cap[u][v] > flow[u][v])
{
p[v]=u;
a[v]=a[u] > cap[u][v] - flow[u][v] ? cap[u][v] - flow[u][v]:a[u];
q.push(v);
}
}
}
if(!a[t]) break;
for(u=t;u!=s;u=p[u])
{
flow[p[u]][u]+=a[t];
flow[u][p[u]]-=a[t];
}
max+=a[t];
}
return max;
}
int main()
{
//freopen("1459.txt","r",stdin);
int i,j,k;
int u,v;
int cost;
while(scanf("%d%d%d%d ",&n,&np,&nc,&m)!=EOF)//注意输入中的空格也要过滤掉
{
memset(cap,0,sizeof(cap));
for(i=1;i<=m;i++)
{
scanf("(%d,%d)",&u,&v);
scanf("%d ",∩[u][v]);
//printf("(%d,%d)",u,v);
//printf("%d ",cap[u][v]);
}
for(i=1;i<=np;i++)
{
scanf("(%d)%d ",&u,&cost);
//printf("(%d)%d ",u,cost);
cap
[u]=cost;
}
for(i=1;i<=nc;i++)
{
scanf("(%d)%d ",&u,&cost);
//printf("(%d)%d ",u,cost);
cap[u][n+1]=cost;
}
int ans=maxflow(n,n+1);//设源点S=n和汇点T=n+1;
printf("%d/n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: