您的位置:首页 > 其它

2739 Sum of Consecutive Prime Numbers

2010-09-11 19:53 239 查看
Sum of Consecutive Prime Numbers

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9363Accepted: 5371
Description
Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.
Input
The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.
Output
The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.
Sample Input
2
3
17
41
20
666
12
53
0

Sample Output
1
1
2
3
0
0
1
2

Source
从今天开始每天刷一个WP,这是今天的WP。
#include<iostream>
using namespace std;
int prime_number[1300];

int prime(int x)
{
for(int i=2;i<x/2+1;i++)
if(x%i==0)
return 0;
return 1;
}

int main()
{
prime_number[0]=2;
int i,j=1,n,k,num;
for(i=3;i<=10000;i=i+2)
if(prime(i))
{
prime_number[j]=i;
j++;
}
num=j;
while(cin>>n&&n)
{
int count=0,temp=0;
for(i=0;i<num;i++)
{
if(prime_number[i]>n)
break;
for(j=0;j<=i;j++)
{
int temp=0;
for(k=j;k<=i;k++)
{
temp +=prime_number[k];
if(temp>n)//首先这条语句没有加,果然超时了。和谐社会,还是不能用暴力啊!
break;
}
if(temp==n)
count++;
}
}
cout<<count<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: