您的位置:首页 > Web前端

二分图匹配(简单题)POJ 1274 The Perfect Stall

2010-09-05 19:46 429 查看
The Perfect Stall

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 8898Accepted: 4136
Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

Sample Output
4


/*
题目大意:n头牛到m个畜栏,每头牛只有在自己喜欢的畜栏产奶,求最大产奶量;
题目求解:很明显匈牙利算法求二分图最大匹配.
PS:刚开始没看懂输入输出,纠结了半天(还以为会有不同畜栏的产奶量,要用最大流做),写代码花了2-3分就写完了,1Y,这题真的是基础的一塌糊涂.
Source Code

Problem: 1274   User: wawadimu
Memory: 348K   Time: 16MS
Language: C++   Result: Accepted

Source Code
*/
#include<iostream>
using namespace std;

#define maxn 210
int map[maxn][maxn];
int match[maxn];
bool vis[maxn];
int n,m;//n(num_cow),m(num_stall)

bool dfs(int u)
{
for(int v=1;v<=n;v++)
{
if(!vis[v] && map[u][v])
{
vis[v]=true;
if(match[v]==0 || dfs(match[v]))
{
match[v]=u;
return true;
}
}
}
return false;
}
int main()
{
//freopen("1274.txt","r",stdin);
int i,k,j;
int cnt;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(map,0,sizeof(map));
memset(match,0,sizeof(match));
for(i=1;i<=n;i++)
{
scanf("%d",&cnt);
while(cnt--)
{
scanf("%d",&k);
map[i][k]=1;
}
}
int ans=0;
for(i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i)) ans++;
}
printf("%d/n",ans);
}
return 1;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: