您的位置:首页 > 编程语言 > PHP开发

PKU2533 最长上升子序列 DP

2010-08-20 16:45 357 查看
Longest Ordered Subsequence


Time Limit:

2000MS

 

Memory Limit:

65536K

Total Submissions:

15397

 

Accepted:

6552

Description


A numeric sequence of ai
is ordered if a1
< a2
< ... < aN
. Let the subsequence of the given numeric sequence (a1
, a2
, ..., aN
) be any sequence (ai1
, ai2
, ..., aiK
), where 1 <= i1
< i2
< ... < iK
<= N
. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input


The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output


Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input


7

1 7 3 5 9 4 8

Sample Output


4

 

 

毫无疑问
,

最长上升子序列


当作练习
nlogn

的算法把它水掉了


代码如下
:

 
 
#include<stdio.h>
#include<string.h>
#define MAXN 1005
int i,n,a[MAXN],c[MAXN],len[MAXN],pos,max,total;
int find(int a,int l,int r)
{
int mid=(l+r)/2;
while (l<=r)
{
if (c[mid]==a) return mid;
else
{
if (a>c[mid]) l=mid+1;
else r=mid-1;
mid=(l+r)/2;
}
}
return l;
}
int main()
{
while (scanf("%d",&n)!=EOF)
{
for (i=1;i<=n;++i) scanf("%d",&a[i]);
for (i=1;i<=n;++i) c[i]=20000;
c[1]=a[1];
len[1]=1;
total=1;
max=1;
for (i=1;i<=n;++i)
{
pos=find(a[i],1,total+1);
c[pos]=a[i];
len[i]=pos;
if (pos>max) {max=pos;total++;}
}
printf("%d/n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息