您的位置:首页 > 编程语言 > PHP开发

PKU1458 最长公共字串 DP

2010-08-18 09:46 375 查看
Common Subsequence


Time Limit:

1000MS

 

Memory Limit:

10000K

Total Submissions:

20435

 

Accepted:

7752

Description


A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij
= zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input


The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output


For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input


abcfbc        
abfcab

programming   
contest

abcd          
mnp

Sample Output


4

2

0

 

 

 

DP

的经典应用
:

求最长公共字串
.

转移方程
:     
(res[i][j]:

表示
stringa

的前
i

个字符和
stringb

的前
j

个字符的最长公共字串长度
)

res[i][j]=0                   
             
      
(i==0||j==0)

res[i][j]=res[i-1][j-1]+1
             
      
(stringa[i]==stringb[j])

res[i][j]=max(res[i][j-1],res[i-1][j])     
(stringa[i]!=stringb[j])

 

代码如下
:

 
#include<stdio.h>
#include<string.h>
#define MAXN 1005
int main()
{
int i,j,la,lb,res[MAXN][MAXN];char a[MAXN],b[MAXN];
while (scanf("%s%s",a,b)!=EOF)
{
memset(res,0,sizeof(res));
la=strlen(a);lb=strlen(b);
for (i=0;i<la;++i)
for (j=0;j<lb;++j)
if (a[i]==b[j]) res[i+1][j+1]=res[i][j]+1;
else res[i+1][j+1]=res[i][j+1]>res[i+1][j]?res[i][j+1]:res[i+1][j];
printf("%d/n",res[la][lb]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  input output each zk c