您的位置:首页 > 其它

PKU 2406(KMP算法的灵活应用)

2010-08-15 21:17 197 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 13798Accepted: 5754
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

#include <stdio.h>
#include <string.h>
#define maxn 1000005

int next[maxn];
int len;

void getnext(char str[])
{
next[0] = -1;
int i=0;
int j=-1;
while (i<len)
{
if (j==-1||str[i]==str[j])
{
i++;
j++;
next[i] = j;
} else {
j=next[j];
}
}
}

int main()
{
char str[maxn];
while (scanf("%s",str))
{
if(strcmp(str,".") == 0)
break;
len = strlen(str);
getnext(str);
if(next[len]==0)
{
printf("1/n");
continue;
}
printf("%d/n",len%(len-next[len])==0?len/(len-next[len]):1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: