您的位置:首页 > 其它

poj2406解题报告

2010-08-14 08:57 309 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 13765Accepted: 5738
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

题意:求一个字符串中最多有多少重复的子串

思路:暴力搜索

#include<iostream>
using namespace std;
char str[1000010];
int main()
{
	int i,j,k,len;
	while(scanf("%s",&str[1])&&strcmp(".",&str[1]))
	{
		len=strlen(&str[1]);
		for(i=1;i<=len;i++)
		{
			if(len%i==0)
			{
				for(j=1;j<=(len-i)/i;j++)
				{
					for(k=1;k<=i;k++)
					{
						if(str[k]!=str[j*i+k])
							goto end;
					}

				}
				cout<<len/i<<endl;
				goto exit;
			}
end:		i=i;
		}
exit:		i=i;
	}

	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: