您的位置:首页 > 其它

PKU 1936 All in All

2010-08-08 16:53 169 查看
All in All

Time Limit:
1000MS
Memory Limit:
30000K
Total Submissions:
16864
Accepted:
6633
Description
You
have devised a new encryption technique which encodes a message by
inserting between its characters randomly generated strings in a clever
way. Because of pending patent issues we will not discuss in detail how
the strings are generated and inserted into the original message. To
validate your method, however, it is necessary to write a program that
checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a
subsequence of t, i.e. if you can remove characters from t such that the
concatenation of the remaining characters is s.

Input
The
input contains several testcases. Each is specified by two strings s, t
of alphanumeric ASCII characters separated by whitespace.The length of s
and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output
Yes

No

Yes

No

Source
Ulm Local 2002

代码:

]#include <iostream>
#include <string>
using namespace std;
int main()
{
int i,j;
string a,b;
while(cin>>a>>b)
{
bool ok=0;
if(a.size()>b.size())
{
cout<<"No"<<endl;
}
else
{
i=0;
j=0;
while(i<b.size())
{
//cout<<b[i]<<a[j]<<endl;
if(a[j]==b[i])
{
j++;
if(j==a.size())
{
ok=1;
break;
}
i++;
}
else
{
i++;
}
}
}
printf("%s/n",ok?"Yes":"No");
}
return  0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: