您的位置:首页 > 其它

PKU 1477 Box of Bricks

2010-08-06 16:01 302 查看
Box of Bricks

Time Limit:
1000MS
Memory Limit:
10000K
Total Submissions:
9698
Accepted:
4233
Description
Little
Bob likes playing with his box of bricks. He puts the bricks one upon
another and builds stacks of different height. "Look, I've built a
wall!", he tells his older sister Alice. "Nah, you should make all
stacks the same height. Then you would have a real wall.", she retorts.
After a little con- sideration, Bob sees that she is right. So he sets
out to rearrange the bricks, one by one, such that all stacks are the
same height afterwards. But since Bob is lazy he wants to do this with
the minimum number of bricks moved. Can you help?



Input
The
input consists of several data sets. Each set begins with a line
containing the number n of stacks Bob has built. The next line contains n
numbers, the heights hi of the n stacks. You may assume 1 <= n <=
50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of
stacks. Thus, it is always possible to rearrange the bricks such that
all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output
For
each set, first print the number of the set, as shown in the sample
output. Then print the line "The minimum number of moves is k.", where k
is the minimum number of bricks that have to be moved in order to make
all the stacks the same height.

Output a blank line after each set.
Sample Input
6

5 2 4 1 7 5

0

Sample Output
Set #1

The minimum number of moves is 5.

Source
Southwestern European Regional Contest 1997

这不是个模拟题是个数学题,很明显要从比平均数多的砖堆上移走砖块到比平均数的砖堆上,这样一想就很简单了,算出平均数,分别取差的绝对值,加起来除2就是答案了。
代码如下:
]#include <iostream>
using namespace std;
int main()
{
int box[55];
int n;
int i;
int sum;
int k=1;
while(cin>>n&&n)
{
sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&box[i]);
sum+=box[i];
}
int average=sum/n;
sum=0;
for(i=0;i<n;i++)
{
sum+=average-box[i]>0?average-box[i]:box[i]-average;
}
printf("Set #%d/nThe minimum number of moves is %d./n/n",k++,sum/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: