您的位置:首页 > 其它

1704 Georgia and Bob 尼姆博弈变形

2010-08-05 10:27 323 查看
Georgia and Bob

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 3404Accepted: 783
Description
Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:



Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output
For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output
Bob will win
Georgia will win

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[1100];
int main()
{
int ci;cin>>ci;
while(ci--)
{
int n;cin>>n;
for(int i=1;i<=n;i++) cin>>a[i];
sort(a+1,a+n+1);
int ans=0;
for(int i=n;i>=1;i--)
{
ans^=a[i]-a[i-1]-1;//转换成取石子的尼姆博弈问题
}
if(ans) cout<<"Georgia will win"<<endl;
else cout<<"Bob will win"<<endl;
}
return 0;
}
/*
将棋子从右端向左端每相邻两个分成一对如果只剩下一个就在棋盘左端加一格与之配对,
当对手移动一组中的左边一个棋子时,我们只需要将靠右的移动相同的步骤数即可。
同时把一组中两个棋子距离视为一堆石头,当对手移动靠右边的石头时就变成经典的取石子游戏了。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: