您的位置:首页 > 其它

HDU 1068(图论,二分匹配)

2010-07-31 08:21 369 查看

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2105 Accepted Submission(s): 915


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0


Sample Output

5
2
#include <iostream>
#include <vector>
using namespace std;
#define MAX 1005

vector< vector<int> > map;
int mark[MAX];
bool flag[MAX];
int nm,num;

bool dfs(int pos)     //搜pos点是否存在增广路
{
int i,pre,tp;
int len=map[pos].size();
for(i=0;i<len;i++)
{
tp=map[pos][i];
if(!flag[tp])
{
flag[tp]=true;
pre=mark[tp];
mark[tp]=pos;
if(pre==-1 || dfs(pre)) return true;    //如果没被访问过或者存在增广路,pos到该点就存在增广路
mark[tp]=pre;          //否则pos到该点就不存在增广路
}
}
return false;
}

int main()
{
int n,m,i;
while (scanf("%d",&n)!=EOF)
{
num=0;
nm=n+n;
map.clear();
map.resize(nm+10);
memset(mark,-1,sizeof(mark));
int temp=n;
int x,y;
while (temp--)
{
scanf("%d: (%d)",&x,&m);
while (m--)
{
scanf("%d",&y);
y+=n;
map[x+1].push_back(y+1);
}
}
for (i=1;i<=n;i++)
{
memset(flag,0,sizeof(flag));
if(dfs(i)) num++;
}
printf("%d/n",n-num/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: