您的位置:首页 > 其它

poj 2349 最小生成数 允许k个孤立点-k已知-求点之间允许的距离的最小值

2010-07-30 12:12 323 查看
Arctic Network

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 2946Accepted: 1096
Description
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1
2 4
0 100
0 300
0 600
150 750

Sample Output
212.13

Source
Waterloo local 2002.09.28
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int inf=(1<<28);
class Point
{
public:
int x,y;
};
Point point[510];//point
double a[510][510];//distance
double ans[510];//存最小生成数的边
double dis(Point a,Point b)
{
return sqrt(0.0+(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));//注意加上0.0,否则编译错误
}
int main()
{
int ci;scanf("%d",&ci);
while(ci--)
{
int k,n;scanf("%d%d",&k,&n);//n 点数;k ,卫星数量
for(int i=0;i<n;i++) scanf("%d%d",&point[i].x,&point[i].y);
for(int i=0;i<n;i++) for(int j=0;j<n;j++) a[i][j]=dis(point[i],point[j]);
int vis[510];
double lowc[510];
memset(vis,0,sizeof(vis));
vis[0]=1;
int cnt=0;//最小生成树的边的个数
for(int i=0;i<n;i++) lowc[i]=a[0][i];
for(int j=1;j<n;j++)
{
double minc=double(inf);int p=-1;
for(int i=0;i<n;i++)
{
if(vis[i]==0)
{
if(minc>lowc[i])
{
minc=lowc[i];
p=i;
}
}
}
if(minc==inf) break;
ans[cnt++]=minc;
vis[p]=1;
for(int i=0;i<n;i++)
{
if(vis[i]==0&&lowc[i]>a[p][i]) lowc[i]=a[p][i];
}
}
sort(ans,ans+cnt);
printf("%.2lf/n",ans[cnt-k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: