您的位置:首页 > 其它

HDU 3371(最小生成树,Prim)

2010-07-26 21:05 281 查看

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1271 Accepted Submission(s): 423


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6


Sample Output

1
#include <stdio.h>
#include <string.h>
#define MAX 505
#define MAXCOST 0x7fffffff

int sum,flag,num;

void Prim(int graph[][MAX],int n)
{
int i,j,k,min;
int lowcost[MAX];
int adjvex[MAX];
for(i=1;i<n;i++)
lowcost[i]=graph[0][i];   //从第一个的顶点开始
memset(adjvex,0,sizeof(adjvex));
min=MAXCOST;
for(i=1;i<n;i++)
{
min=MAXCOST;
for(j=1;j<n;j++)
if(adjvex[j]==false && lowcost[j]<min)
{
min=lowcost[j];
k=j;    //记下最小的点
}
adjvex[k]=true;   //为true表示该权值已经是最小,为flase是还不确定,应继续更新
for(j=1;j<n;j++)
{
if(adjvex[j]==false && lowcost[j]>graph[k][j])  //更新lowcost
lowcost[j]=graph[k][j];
}
}
for(i=1;i<n;i++)
{
if(lowcost[i]!=MAXCOST)
{
sum+=lowcost[i];  //这就是最小生成树
num++;
}
}
}

int main()
{
int n,m,i,j,x,y,a,b,c;
int graph[MAX][MAX],q[MAX];
scanf("%d",&m);
while (m--)
{
flag=0;
num=0;
scanf("%d%d%d",&n,&x,&y);   //顶点个数
for(i=0;i<n;i++)
for(j=0;j<n;j++)
graph[i][j]=MAXCOST;
while(x--)
{
scanf("%d%d%d",&a,&b,&c);
if(graph[a-1][b-1]>c)
graph[a-1][b-1]=graph[b-1][a-1]=c;
}
while(y--)
{
int l,k,p;
scanf("%d",&p);
for(l=0;l<p;l++)
{
scanf("%d",&q[l]);
q[l]--;
}
for(k=0;k<p;k++)
for(l=0;l<p;l++)
graph[q[k]][q[l]]=graph[q[l]][q[k]]=0;
}
sum=0;
Prim(graph,n);
if(num==n-1)
flag=1;
if(flag)
printf("%d/n",sum);
else
printf("-1/n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: