您的位置:首页 > 其它

POJ 1032 Parliament

2010-07-26 14:25 225 查看
Parliament

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11284Accepted: 4694
Description
New convocation of The Fool Land's Parliament consists of N delegates. According to the present regulation delegates should be divided into disjoint groups of different sizes and every day each group has to send one delegate to the conciliatory committee. The composition of the conciliatory committee should be different each day. The Parliament works only while this can be accomplished.
You are to write a program that will determine how many delegates should contain each group in order for Parliament to work as long as possible.

Input
The input file contains a single integer N (5<=N<=1000 ).
Output
Write to the output file the sizes of groups that allow the Parliament to work for the maximal possible time. These sizes should be printed on a single line in ascending order and should be separated by spaces.
Sample Input
7

Sample Output
3 4

Source
Northeastern Europe 1998
题目大意:给个数N 求出相加得N且相乘最大的几个不同的数
题目分析:相乘最大 那就让数多点儿 从2往上开始算 多余的数加到大的上面去
代码如下:
#include <iostream>
using namespace std;
int main()
{
int n,i,j,k=0,a[100],t;
cin>>n;
for(i=2;k+i<=n;i++){
k+=i;
a[i]=i;
}
k=n-k;
while(k)
for(t=i-1;t>=2&&k;t--)
a[t]++,k--;

for(t=2;t<i;t++)
if(t==i-1)cout<<a[t]<<endl;
else cout<<a[t]<<" ";
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: