您的位置:首页 > 其它

HDU 2612(搜索题,BFS)

2010-07-24 16:42 369 查看

Find a way

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 403 Accepted Submission(s): 129


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#


Sample Output

66
88
66


#include <iostream>
#include <queue>
using namespace std;
#define N 205

struct node
{
int x,y,step;
};

char a

;
node sss[1000];
int ans1[1001],ans2[1001],ans[1001],mark

;
int x1,y1,x2,y2,Min,cnt;
int dis[4][2]={{0,1},{1,0},{0,-1},{-1,0}};

int judge(int x,int y)
{
int i;
for(i=1;i<cnt;i++)
{
if(sss[i].x==x && sss[i].y==y)
return i;
}
return 0;
}
void BFS_Y(int x,int y)
{
queue<node> q;
node s1,s2;
s1.x=x;
s1.y=y;
s1.step=0;
q.push(s1);
int i;
memset(ans,0,sizeof(ans));
memset(mark,0,sizeof(mark));
mark[s1.x][s1.y]=1;
while(!q.empty())
{
s1=q.front();
q.pop();
int t=judge(s1.x,s1.y);
if(t)
{
mark[s1.x][s1.y]=1;
ans[t]=s1.step;
}
for(i=0;i<4;i++)
{
s2=s1;
s2.x+=dis[i][0];
s2.y+=dis[i][1];
s2.step++;
if((a[s2.x][s2.y]=='.' || a[s2.x][s2.y]=='@') && mark[s2.x][s2.y]==0)
{
q.push(s2);
mark[s2.x][s2.y]=1;
}
}
}
for(i=1;i<cnt;i++)
{
if(ans[i]) ans1[i]=ans[i];
else ans1[i]=-1;
}
}

void BFS_M(int x,int y)
{
queue<node> q;
node s1,s2;
s1.x=x;
s1.y=y;
s1.step=0;
q.push(s1);
int i;
memset(ans,0,sizeof(ans));
memset(mark,0,sizeof(mark));
mark[s1.x][s1.y]=1;
while(!q.empty())
{
s1=q.front();
q.pop();
int t=judge(s1.x,s1.y);
if(t)
{
mark[s1.x][s1.y]=1;
ans[t]=s1.step;
}
for(i=0;i<4;i++)
{
s2=s1;
s2.x+=dis[i][0];
s2.y+=dis[i][1];
s2.step++;
if((a[s2.x][s2.y]=='.' || a[s2.x][s2.y]=='@') && mark[s2.x][s2.y]==0)
{
q.push(s2);
mark[s2.x][s2.y]=1;
}
}
}
for(i=1;i<cnt;i++)
{
if(ans[i]) ans2[i]=ans[i];
else ans2[i]=-1;
}
}

int main()
{

int n,m,i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
getchar();
Min=99999;
cnt=1;
memset(a,'#',sizeof(a));
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
scanf("%c",&a[i][j]);
if(a[i][j]=='Y')
{
x1=i;y1=j;
}
else if(a[i][j]=='M')
{
x2=i;y2=j;
}
else if(a[i][j]=='@')
{
sss[cnt].x=i;
sss[cnt++].y=j;
}
}
getchar();
}
BFS_Y(x1,y1);
BFS_M(x2,y2);
for(i=1;i<cnt;i++)
{
if(ans1[i]!=-1 && ans2[i]!=-1)
{
int t=ans1[i]+ans2[i];
if(t<Min)
Min=t;
}
}
printf("%d/n",Min*11);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: