您的位置:首页 > 其它

2844 Coins hdu 一些数字生成小于等于m的数的个数转换成多重背包问题

2010-07-21 08:03 363 查看

Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 695 Accepted Submission(s): 277


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output
For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0


Sample Output

8
4#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[100006],a[200],w[200],num[200];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)==2)
{
if(n==0&&m==0) break;
for(int i=0;i<n;i++) {cin>>a[i];w[i]=a[i];}
for(int i=0;i<n;i++) cin>>num[i];
memset(f,0,sizeof(f));
for(int i=0;i<n;i++)
{
if(a[i]*num[i]>m) //完全背包
{
for(int j=a[i];j<=m;j++) f[j]=max(f[j],f[j-a[i]]+w[i]);
}
else
{
int l=num[i],k=1;
while(k<l)
{
for(int j=m;j>=k*a[i];j--) f[j]=max(f[j],f[j-k*a[i]]+k*w[i]);
l-=k;
k*=2;
}
for(int j=m;j>=l*a[i];j--) f[j]=max(f[j],f[j-l*a[i]]+l*w[i]);
}
}
int cnt=0;
for(int i=1;i<=m;i++)
{
//cout<<f[i]<<"..";
if(f[i]==i) cnt++;
}//cout<<endl;
printf("%d/n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐