您的位置:首页 > 大数据 > 人工智能

PKU 1273 Drainage Ditches

2010-07-05 16:58 204 查看
Drainage Ditches

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21076 Accepted: 7554
Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output
50

Source
USACO 93
感谢ZZC大牛,感谢ZZC让我过了第一个SAP
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int flow[210][210],dist[210]={0},gap[210]={0};
int find_way(int p,int limit=0x3f3f3f3f)
{
    if(p==n-1)  return limit;
    for(int i=0;i<n;i++)
    if(dist[p]==dist[i]+1 && flow[p][i]>0)
    {
        int t=find_way(i,min(limit,flow[p][i]));
        if(t<0) return t;
        if(t>0)
        {
            flow[p][i]-=t;
            flow[i][p]+=t;
            return t;
        }   
    }   
    int label =n;//设置是为了不超过真实距离
    for(int i=0;i<n;i++) if(flow[p][i]>0) label=min(label,dist[i]+1);
    if(--gap[dist[p]] == 0 || dist[0] >= n) return -1;//为什么是大于等于
 ++gap[dist[p] = label];
 return 0;
}   
int sap()
{
    gap[0]=n;
    int t=0,maxflow=0;
    while((t=find_way(0))>=0)
         maxflow+=t;
    return maxflow;
}       
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(flow,0,sizeof(flow));//悲剧,忘了
        memset(gap,0,sizeof(gap));
        memset(dist,0,sizeof(dist));
        for(int i=0;i<m;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            --x;--y;
            flow[x][y]+=c;
        }    
        printf("%d/n",sap());
    }   
    return 0;
}   
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息