您的位置:首页 > 其它

ZOJ Problem Set - 1016

2010-07-02 14:39 423 查看
Parencodings

Time Limit: 1 Second Memory Limit: 32768 KB

Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

ParenCoding

// 1016Parencodings.cpp : Defines the entry point for the console application.
//

#include <iostream>
using namespace std;

template<class T>
class CStack
{
T content[400];
int index;
public:
CStack() : index(0) {}
void push(T value) { if (index < 400) content[index++] = value;}
T pop() { return content[--index]; }
bool empty() { return index == 0;}
};
void TestParentheses(char* Array, int len)
{
for (int i = 0; i < len; ++i)
{
cout << Array[i];
}
cout << endl;
}
void ParenCoding(char* Array, int len)
{
CStack<int> stk;
for (int i = 0; i < len; ++i)
{
if (Array[i] == '(')
{
stk.push(0);
}
else if (Array[i] == ')')
{
if (stk.empty())
throw "Mismatch parentheses!";
int newObj = 0;
int obj = stk.pop();
while (obj > 0)
{
if (stk.empty())
throw "Mismatch parentheses!";
newObj += obj;

obj = stk.pop();
}
++newObj;
cout << newObj << ' ';
stk.push(newObj);
}
else
{
throw "Invalid input char!";
}
}
cout << endl;

int obj = stk.pop();
if (!stk.empty() || obj != len / 2)
throw "Mismatch parentheses!";

}
int main()
{
int set;
cin >> set;
while (set--)
{
int n;
cin >> n;
char* pParentheses = new char[2 * n];
for (int i = 0, j = 0, k = 0; i < n && j < 2 * n; ++i)
{
int l;
cin >> l;
for (; k < l; ++k)
pParentheses[j++] = '(';
pParentheses[j++] = ')';
}
//        TestParentheses(pParentheses, 2 * n);
try
{
ParenCoding(pParentheses, 2 * n);
}
catch (const char* e)
{
cout << e << endl;
}
delete[] pParentheses;
}
return 0;
}


还是无法AC,找不出bug,水平有限啊。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: