您的位置:首页 > 其它

POJ 1740 A New Stone Game

2010-06-18 18:31 274 查看
A New Stone Game

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 2805Accepted: 1418
Description
Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input
The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output
For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input
3
2 1 3
2
1 1
0

Sample Output
1
0


题目大意:有N堆石子两人轮流取 每次必须移走一堆中至少一枚石子 并且可以从一堆移向其他堆任意个石子 先取完算赢
题目分析:若一堆先取赢
若两堆 先取的人可以移走几个把两堆变成相同多的 第二个人再怎么取就学着怎么取 定赢
三堆 取最大一堆 移走一个以上的前提下全分配给前两堆且使前两堆数量相同
四堆 最大一堆 移走一个的前提下 使中间两堆变成数量相同 把自己变成和第一堆数量相同
…… 搞定
代码如下:
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int n,a[110],i;
while(cin>>n,n){
for(i=0;i<n;i++)
cin>>a[i];
if(n&1)cout<<"1"<<endl;
else {
sort(a,a+n);
for(i=0;i<n;i+=2)
if(a[i]!=a[i+1])
break;
if(i==n)cout<<"0"<<endl;
else cout<<"1"<<endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: