您的位置:首页 > 其它

acm pku 1045 Bode Plot的计算过程

2010-05-24 23:03 399 查看
Bode Plot
Description
Consider the AC circuit below. We will assume that the circuit is in steady-state. Thus, the voltage at nodes 1 and 2 are given by v1 = VS coswt and v2 = VRcos (wt + q ) where VS is the voltage of the source, w is the frequency (in radians per second), and t is time. VR is the magnitude of the voltage drop across the resistor, and q is its phase.

You are to write a program to determine VR for different values of w. You will need two laws of electricity to solve this problem. The first is Ohm's Law, which states v2 = iR where i is the current in the circuit, oriented clockwise. The second is i = C d/dt (v1-v2) which relates the current to the voltage on either side of the capacitor. "d/dt"indicates the derivative with respect to t.
Input
The input will consist of one or more lines. The first line contains three real numbers and a non-negative integer. The real numbers are VS, R, and C, in that order. The integer, n, is the number of test cases. The following n lines of the input will have one real number per line. Each of these numbers is the angular frequency, w.
Output
For each angular frequency in the input you are to output its corresponding VR on a single line. Each VR value output should be rounded to three digits after the decimal point.
Sample Input
1.0 1.0 1.0 9

0.01

0.031623

0.1

0.31623

1.0

3.1623

10.0

31.623

100.0

Sample Output
0.010

0.032

0.100

0.302

0.707

0.953

0.995

1.000

1.000

Source
Greater New York 2001



结果要求输出小数点后3位数,具体实现如下: 
#include <iostream>
#include <iomanip>
#include <math.h>
using namespace std;

int main(void)
{
double Vs, R, C, w;
int n;

cin >> Vs >> R >> C >> n;
while(n --)
{
cin >> w;
cout << setiosflags(ios::fixed)<< setprecision(3) << Vs * R * C * w /sqrt(1+C*C*w*w)<< endl;
}

return 0;
}

提交结果:

Problem: 1045
User: uestcshe
Memory: 216K
Time: 0MS
Language: C++
Result: Accepted
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: