您的位置:首页 > 其它

PKU 3169 layout 【差分约束系统】

2010-05-01 16:39 351 查看
题目:

Layout
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 1772Accepted: 856
Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.Sample Input

4 2 1
1 3 10
2 4 20
2 3 3
Sample Output

27
Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.Source

USACO 2005 December Gold

差分约束方程有三个:

max和min 分别代表max(a,b)和min(a,b)

s[max] - s[min] <=apart

s[max] - s[min] > =apart

s[i] - s[i-1] >=0.

然后建图做spfa,如果做spfa时发现存在负权环,则不存在解。

如果dis
=INF则任意远都满足约束条件。

否则dis
就是最远的可能距离。

差分约束时,做最短路得到的是最大值,做最长路是得到最小值。

代码#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
const int N = 1010;
const int M = 10000*3;
const int INF = 0x7f7f7f7f;
struct Edge
{
int to,dis;
Edge *next;
};
Edge edges[M];
Edge * adj
;
int cnt = 0;
void addEdge(int s,int e,int w)
{
Edge *ptr = &edges[cnt++];
ptr->to = e;
ptr->dis = w;
ptr->next = adj[s];
adj[s] = ptr;
}
int n,ml,md;
int maxt;
int dis
;
bool vis
;
int vCnt
;
int spfa()
{
queue <int > Q;
memset(vis,false,sizeof(vis));
memset(dis,127,sizeof(dis));
memset(vCnt,0,sizeof(vCnt));
dis[1] = 0;
Q.push(1);
vCnt[1] = 1;
while(!Q.empty())
{
int u =Q.front();Q.pop();
vis[u] = false;
for(Edge *ptr= adj[u];ptr;ptr=ptr->next)
{
int v = ptr->to;
int cost = ptr->dis;
if(dis[u]<INF&&dis[v]>dis[u]+cost)
{
dis[v] = dis[u] + cost;
if(!vis[v])
{
Q.push(v);
vCnt[v]++;
if(vCnt[v]>=n)
{
return -1;
}

}
}
}
}
if(dis[maxt]<INF)
{
return dis[maxt];
}
return -2;

}
int main()
{
maxt = 0;
int a,b,d;
scanf("%d%d%d",&n,&ml,&md);
for(int i=1;i<=ml;i++)
{
scanf("%d%d%d",&a,&b,&d);
if(a>b)
{
swap(a,b);
}
if(b>maxt)
{
maxt = b;
}
addEdge(a,b,d);
}
for(int i=1;i<=md;i++)
{
scanf("%d%d%d",&a,&b,&d);
if(a>b)
{
swap(a,b);
}
if(b>maxt)
{
maxt = b;
}
addEdge(b,a,-d);
}
for(int i=2;i<=maxt;i++)
{
addEdge(i,i-1,0);
}
printf("%d\n",spfa());
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: