您的位置:首页 > 其它

Foj 1543 Avoid The Lakes

2010-04-23 22:16 225 查看

Accept: 167 Submit: 244
Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.
The farm is represented as a rectangular grid with N (1<=N<=100) rows and M (1<=M<=100) columns. Each cell in the grid is either dry or submerged, and exactly K (1<=K<=N*M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

The input will consist of several datasets.
Each dataset contains two parts:
*Line 1: Three space-separated integers: N, M, and K.
*Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C.
Input is terminated by end of file.

Output

For each dataset,you should output the number of cells that the largest lake contains.

Sample Input

3 4 5 3 2 2 2 3 1 2 3 1 1

Sample Output

4

Hint

Input Details:
The farm is a grid with three rows and four columns; five of the cells are submerged. They are located in the positions (row 3, column 2); (row 2, column 2); (row 3, column 1); (row 2, column 3); (row 1, column 1):

# . . .
. # # .
# # . .

很水的题目, dsf

#include<iostream>
using namespace std;
int map[102][102];
int dsf(int i,int j)
{
int sum=1;
map[i][j]=0;
if(map[i-1][j]==1) sum+=dsf(i-1,j);
if(map[i+1][j]==1) sum+=dsf(i+1,j);
if(map[i][j-1]==1) sum+=dsf(i,j-1);
if(map[i][j+1]==1) sum+=dsf(i,j+1);
return sum;
}
int main()
{
int n,m,k,i,j,x,y,max,tmp;
while(scanf("%d%d%d",&n,&m,&k)!=EOF)
{
for(i=0;i<k;i++)
{
scanf("%d%d",&x,&y);
map[x][y]=1;
}
max=0;
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
{
if(map[i][j]==1)
{
tmp=dsf(i,j);
if(max<tmp) max=tmp;
}
}
printf("%d/n",max);
}
return 0;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: