您的位置:首页 > 其它

ZOJ 省赛题 Somali Pirates

2010-04-20 15:03 148 查看
Somali Pirates



Time Limit:1 Second Memory Limit:32768 KB



It is said that the famous Somali Pirates hate digits. So their QQ passwords never contain any digit. Given some lines of candidate passwords, you are asked to delete all the digits in the passwords and print other characters in their original order. So the Somali Pirates can use them as their QQ passwords^^
Input
There are multiple test cases. The first line of input is an integer T (T <= 10) indicating the number of test cases.
Each case contains a line indicating a candidate password. The length of the password is between 1 and 20, inclusive. Besides, the password consists of only digits and English letters.
Output
For each candidate password, delete all the digits and print the remaining characters in a line.
Sample Input
2
BeatLA123
1plus1equals1

Sample Output
BeatLA
plusequals



我的程序

import java.util.*;
public class ZOJ2 {
public static void main(String[] args){
Scanner cin=new Scanner(System.in);
int t=cin.nextInt();
while(t!=0){
t--;
char[] chr=new char[20];//申请char数组
int j=0;
while(true){
String c=cin.next();//输入字符串
for(int i=0;i<c.length();i++){//字符串转换成char,依次判断单个字符是否为数字;
if(c.charAt(i)<48||c.charAt(i)>57)
chr[j++]=c.charAt(i);//将不是数字的单个字符存入chr数组
}
for(int i=0;i<j;i++)
System.out.print(chr[i]);//输出chr数组
System.out.println();
break;
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: