您的位置:首页 > 其它

ELFhash字符串散列函数——HDU1004

2010-04-19 20:19 218 查看
Problem Description
Contest
time again! How excited it is to see balloons floating around. But to
tell you a secret, the judges' favorite time is guessing the most
popular problem. When the contest is over, they will count the balloons
of each color and find the result.

This year, they decide to leave this lovely job to you.




Input
Input
contains multiple test cases. Each test case starts with a number N (0
< N <= 1000) -- the total number of balloons distributed. The
next N lines contain one color each. The color of a balloon is a string
of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.




Output
For
each case, print the color of balloon for the most popular problem on a
single line. It is guaranteed that there is a unique solution for each
test case.




Sample Input

5

green

red

blue

red

red

3

pink

orange

pink

0





Sample Output

red

pink

#include <iostream>
#include <cstring>
using namespace std;

#define table_size 10000

int ELFhash(char* key, long M) {
	unsigned long h = 0;
	while(*key) {
		h = (h << 4) + *key++;
		unsigned long g = h & 0xF0000000L;
		if (g) h ^= g >> 24;
		h &= ~g;
	}
	return h % M;
}

int main(){
	char key[15];
	int cnt,n;
	while(cin >> n){
		if(!n) break;
		cnt = n;
		int table[table_size] = {0};
		char color[15];
		int max = 0;
		int hash;
		while(cnt--){
			cin >> key;
			hash = ELFhash(key, table_size);
			++table[hash];
			if(table[hash] > max){
				max = table[hash];
				strcpy(color, key);
			}
		}
		cout << color << endl;
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: