您的位置:首页 > 其它

ZOJ_2104_Let the Balloon Rise

2010-04-14 15:50 344 查看
ZOJ Problem Set - 2104
Let the Balloon Rise
Time Limit: 1 Second      Memory Limit: 32768 KB
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N < 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

 

Author: WU, Jiazhi
Source: Zhejiang Provincial Programming Contest 2004
Submit    Status #include<iostream>
#include<string>
#include<vector>
using namespace std;typedef struct BallInf{
 string BallColor;
 int BallNum;
}Balloon;int check( string str, Balloon* Ball, int count )
{
 if( count == 0 )
  return -1;
 for( int i = 0; i < count; i++ ){
  if( Ball[i].BallColor == str )
   return i;
 }
 return -1;
}int findMax( Balloon* Ball, int count )
{
 int temp = 0;
 for( int i = 1; i < count; i++ ){
  if( Ball[i].BallNum > Ball[temp].BallNum )
   temp = i;
 }
 return temp;
}
int main(void)
{
 Balloon Ball[1000];
 int n;
 int count;
 string str1;
 cin>>n;
 while( n != 0 ){
  count = 0;
  for( int i = 0; i < n; i++ ){
   cin>>str1;
   if( check( str1, Ball, count ) == -1 ){
    Ball[count].BallColor = str1;
    Ball[count].BallNum = 1;
    count++;
   }
   else
    Ball[check( str1, Ball, count )].BallNum++;
  }
  cout<<Ball[findMax( Ball, count )].BallColor<<endl;
  cin>>n;
 }
 return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  each string input struct up