您的位置:首页 > 编程语言 > PHP开发

poj 1157 简单动态规划

2010-04-10 12:48 399 查看

POJ 1157 LITTLE SHOP OF FLOWERS

Description
You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.
 V A S E S
12345
Bunches1 (azaleas)723-5-2416
2 (begonias)521-41023
3 (carnations)-21

 
5-4-2020
According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

The first line contains two numbers: F, V.

The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.

1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.

F <= V <= 100 where V is the number of vases.

-50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output
The first line will contain the sum of aesthetic values for your arrangement.
Sample Input
3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output
53

Source
IOI 1999
老一套,二维DP,dp[i][j]保存的是只种前i种花,最多占用到第j个花盆的情况下,最大美学值。
递推公式为“dp[i,j]=max(dp[i-1,k-1]+A[i,k]),其中i<=k<=j,A[i,k]为第i束花插在第k个花瓶中的美学值”
具体编码过程要注意:
注意递推条件,即当a[i,k]为负时,如果dp[i,j]==0则直接赋值,不做比较,因为当前这步的递推必须要有一个选择,如果a[i,k]为正,则直接赋值与比较出较大的再赋值结果相同。如果a[i,k]为负,则直接赋值,作出选择。
另外,此题我是从当前行向下行递推。当然从当前行向上行搜索也可。
#include<iostream>
using namespace std;
int a[110][110];
int dp[110][110];
int main()
{
    int f,v;
    cin>>f>>v;
    for(int i=1;i<f+1;++i)
    for(int j=1;j<v+1;++j)
    {
        scanf("%d",&a[i][j]);
    }
    for(int i=0;i<110;++i)
    for(int j=0;j<110;++j)
    dp[i][j]=0;
    for(int i=0;i<f;++i)
    {
        for(int j=i;j<=v-f+i;++j)
        {
            for(int k=0;j+k<=v-f+i;++k)
            if(dp[i+1][j+1+k]==0||a[i+1][j+k+1]+dp[i][j]>dp[i+1][j+1+k])
            dp[i+1][j+1+k]=a[i+1][j+k+1]+dp[i][j];
        }
        for(int m=i+1;m<=v-f+i;++m)
        if(dp[i+1][m]>dp[i+1][m+1])
        dp[i+1][m+1]=dp[i+1][m];
    }
    cout<<dp[f][v];
    system("PAUSE");
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息