您的位置:首页 > 其它

HDOJ-1060-Leftmost Digit(求n^n的最高位)

2010-01-22 21:53 393 查看

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2924 Accepted Submission(s): 1026


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4


Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.对一个数num可写为 num=10n + a,  即科学计数法,使a的整数部分即为num的最高位数字numnum=10n + a  这里的n与上面的n不等两边取对数: num*lg(num) = n + lg(a);因为a<10,所以0<lg(a)<1令x=n+lg(a); 则n为x的整数部分,lg(a)为x的小数部分又x=num*lg(num);a=10(x-n)  =  10(x-int(x)))再取a的整数部分即得num的最高位#include <iostream>
#include <math.h>
using namespace std;
int main()
{
int t;
while(cin>>t)
{
while(t--)
{
unsigned long n;
cin>>n;
double x=n*log10(n*1.0);
x-=(__int64)x;
int a=pow(10.0, x);
cout<<a<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: