您的位置:首页 > Web前端

POJ 1013 Counterfeit Dollar

2010-01-02 02:45 197 查看
Description
Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input
The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output
For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.
Sample input
12
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even
AGHL BDEC even
JKI ADE up
J K even
ABCDEF GHIJKL up
ABC DEF even
I J down
ABCDEF GHIJKL up
ABHLEF GDIJKC down
CD HA even
A B up
B A down
A C even
A B up
B C even
DEFG HIJL even
ABC DEJ down
ACH IEF down
AHK IDJ down
ABCD EFGH even
AB IJ even
A L down
EFA BGH down
EFC GHD even
BA EF down
A B up
A C up
L K even
ACEGIK BDFHJL up
ACEGIL BDFHJK down
ACEGLK BDFHJI down
ACEGIK BDFHJL up
ACEGIL BDFHJK down
ACEGLK BDFHJI up

Sample output
K is the counterfeit coin and it is light.
I is the counterfeit coin and it is heavy.
I is the counterfeit coin and it is light.
L is the counterfeit coin and it is light.
B is the counterfeit coin and it is light.
A is the counterfeit coin and it is heavy.
A is the counterfeit coin and it is light.
L is the counterfeit coin and it is heavy.
A is the counterfeit coin and it is light.
A is the counterfeit coin and it is heavy.
L is the counterfeit coin and it is light.
K is the counterfeit coin and it is heavy.

一道有意思的模拟题!

思路:使用数组标记的方法,初始化为0,重的++,轻的--, 数组里面绝对值最大的即为答案,因为怀疑最多次!

#include<iostream>
#include<cstring>
#include<cmath>

using namespace std;

const int silver = 2147483647;
int maximum = -2147483647;
int position;
int main()
{
int time = 3;
int coin[12];
char status[5];
int test;
cin >> test;
while(--test+1)
{
memset(coin,0,sizeof(coin));
maximum = -2147483647;
time = 3;
while(--time+1)
{
char c1[7],c2[7];
cin >> c1 >> c2 >> status;

if(status[0] == 'e')
{
for(int i = 0;i < strlen(c1); ++i)
{
coin[c1[i] - 'A'] = silver;
coin[c2[i] - 'A'] = silver;
}
}
if(status[0] == 'u')
{
for(int i = 0; i < strlen(c1); ++i)
{
if(coin[c1[i] - 'A'] != silver)
coin[c1[i] - 'A'] += 1;
if(coin[c2[i] - 'A'] != silver)
coin[c2[i] - 'A'] -= 1;
}
}
if(status[0] == 'd')
{
for(int i = 0; i < strlen(c1); ++i)
{
if(coin[c1[i] - 'A'] != silver)
coin[c1[i] - 'A'] -= 1;
if(coin[c2[i] - 'A'] != silver)
coin[c2[i] - 'A'] += 1;
}
}
}
for(int i = 0;i < 12;++i)
{
if(coin[i] == silver) continue;
if(abs(coin[i]) > maximum)
{
maximum = abs(coin[i]);
position = i;
}
}
if(coin[position] < 0)
cout << static_cast<char>( position + 'A') << " is the counterfeit coin and it is light."<<endl;
if(coin[position] > 0)
cout << static_cast<char>( position + 'A') << " is the counterfeit coin and it is heavy."<<endl;
}
return 0;
}
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: