您的位置:首页 > 产品设计 > UI/UE

FZU 1160 Common Subsequence

2009-12-21 23:03 204 查看

Accept: 237 Submit: 510
Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab programming contest abcd mnp

Sample Output

4 2 0
//dp,跟前面有一题几乎是一样的(动态规划)
#include<iostream>
using namespace std;
inline int max(int a,int b){return a>b?a:b;}
int num[1000][1000];
char c1[1000],c2[1000];
void f(int n,int m)
{
int i,j;
memset(num,0,sizeof(num));
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
{
if(c1[i-1]==c2[j-1])
num[i][j]=num[i-1][j-1]+1;
else
num[i][j]=max(num[i][j-1],num[i-1][j]);
}
}
int main()
{
int n,m;
while(scanf("%s%s",c1,c2)!=EOF)
{
n=strlen(c1);
m=strlen(c2);
f(n,m);
printf("%d/n",num
[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: