您的位置:首页 > 编程语言 > PHP开发

poj1008 Maya Calendar解答报告

2009-11-26 21:46 453 查看
 以下是poj1008 的解答报告,不知道用了什么算法,只知道经过了N次的修改之后,终于给运行出来了。

Time Limit:
1000ms
Memory limit:
10000kB
题目描述
During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

Haab: 0. pop 0

Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
输入
The date in Haab is given in the following format:
NumberOfTheDay. Month Year

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
输出
The date in Tzolkin should be in the following format:
Number NameOfTheDay Year

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
样例输入

3
10. zac 0
0. pop 0
10. zac 1995

样例输出

3
3 chuen 0
1 imix 0
9 cimi 2801

 

代码:

#include <stdio.h>
#include <string.h>

 

int n;  // n is the number of lines

char Haab[19][7] =
{ "pop", "no", "zip", "zotz", "tzec",/
"xul", "yoxkin", "mol", "chen", "yax", "zac", "ceh",/
"mac", "kankin", "muan", "pax", "koyab", "cumhu","uayet"};

 

char Tzolkin[20][9] =
{ "imix", "ik",  "akbal", "kan", "chicchan", "cimi", "manik", "lamat",/
"muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau"};

 

struct Haab_frm
{
    int day;
    char month[7];
    int year;
}Haab_H[100];  //define the struct to store the Haab

 

struct Tzolkin_frm
{
    int num;
    char day[9];
    int year;
}Tzolkin_T[100];   //define the struct to store the Tzolkin

 

void enter_data(struct Haab_frm Haab_H[]);   // enter the data
void show_data(struct Tzolkin_frm Tzolkin_T[]);  // display the data
void convert_data(struct Haab_frm Haab_H[],struct Tzolkin_frm Tzolkin_T[]);  //convert the data

 

int main(void)
{
    int i;
    printf("enter the number of lines:/n");
    scanf("%d",&n);
    printf("enter the Haab data as /"NumberOfTheDay. Month Year/"./n");
    enter_data(Haab_H);
    convert_data(Haab_H,Tzolkin_T);
    printf("the Tzolkin data is:/n");
    show_data(Tzolkin_T);
    getch();
    return 0;
}

 

void enter_data(struct Haab_frm Haab_H[])
{
    int i;
    for(i=1;i<=n;i++)
    {
        scanf("%d . %s %d",&Haab_H[i].day,Haab_H[i].month,&Haab_H[i].year);
        getchar();
    }
}

 

void show_data(struct Tzolkin_frm Tzolkin_T[])
{
    int i;
    for(i=1;i<=n;i++)
        printf("%d %s %d/n",Tzolkin_T[i].num,Tzolkin_T[i].day,Tzolkin_T[i].year);
}

 

void convert_data(struct Haab_frm Haab_H[],struct Tzolkin_frm Tzolkin_T[])
{
    int i,j;
    signed long days;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=19;j++)
        {
            if(strcmp(Haab_H[i].month,Haab[j-1])==0)
                 days=Haab_H[i].year*365 + (j-1)*20 + Haab_H[i].day + 1;
   // get the Haab_H[i].month from the 'j'
             Tzolkin_T[i].year = days / 260;
             Tzolkin_T[i].num = (days % 260) % 13;
             strcpy(Tzolkin_T[i].day , Tzolkin[days % 20 -1]); 
    // remember to copy the string by using function strcpy
        }
    }
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息