您的位置:首页 > 其它

HDU 1701 ACMer

2009-11-01 21:59 471 查看

ACMer

Time
Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K
(Java/Others)

Total Submission(s): 1095 Accepted Submission(s):
466



Problem Description
There are at least P% and at most Q% students of HDU
are ACMers, now I want to know how many students HDU have at least?



Input
The input contains multiple test cases.

The first
line has one integer,represent the number of test cases.

The following N
lines each line contains two numbers P and Q(P < Q),which accurate up to 2
decimal places.



Output
For each test case, output the minumal number of
students in HDU.



Sample Input

1

13.00 14.10





Sample Output

15


题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1701

解题:

好久没做题,好久没写解题思路了,连简答题都不会做了,下午的月赛挂了,我悲剧了,在此发牢骚了。o(︶︿︶)o唉

好好的一题简答题,硬是WA,浮点型的陷阱,不止一次掉进去了。刚开始看不懂题目,ACMer人数在P%和Q%之间,那么P%的人与Q%的人就不能相同,因为一个是至少,一个是至多。看代码:

#include <iostream>
using namespace std;
int main()
{
	int t,i;double a,b;
	cin>>t;
	while (t--)
	{
		cin>>a>>b;		
		for(i=1;;i++)
		{
			if ((int)(a*i/100)<(int)(b*i/100))
				break;
		}
		cout<<i<<endl;
	}
	return 0;
}


运行浮点型要特别注意,下面的情况经常出现。

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: