您的位置:首页 > 其它

POJ 3267, The Cow Lexicon

2009-10-13 09:34 507 查看
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2856 Accepted: 1252

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input
Line 1: Two space-separated integers, respectively: W and L
Line 2: L characters (followed by a newline, of course): the received message
Lines 3..W+2: The cows' dictionary, one word per line

Output
Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input
6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output
2

Source
USACO 2007 February Silver

// POJ3267.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <string>
using namespace std;

int main(int argc, char* argv[])
{
char words[600][26];
char inw[301];
int W, L;

scanf("%d %d\n",&W,&L);
gets(inw);
for (int i = 0; i < W; ++i)gets(words[i]);

int del[301];
del[L] = 0;
for(int i = L - 1 ; i >= 0 ; --i)
{
del[i] = 301;
for(int j = 0 ; j < W ; j ++)
{
int k = 0,l = i;
for(;words[j][k] && l < L; ++l)
if(words[j][k] == inw[l])k++;

if(!words[j][k])
del[i] = std::min(std::min(del[i],del[i + 1] + 1),del[l] + l - i - k);
else
del[i] = min(del[i], del[i + 1] + 1);
}
}
cout<<del[0]<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: