您的位置:首页 > 其它

POJ 2151, Check the difficulty of problems

2009-10-09 02:45 309 查看
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1015 Accepted: 391

Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output
0.972

Source
POJ Monthly,鲁小石

// POJ2151.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <iomanip>
using namespace std;

int main(int argc, char* argv[])
{
int N,M,T;
double TM[1001][31];

double DP[31][31];
while (cin >> M >> T >> N && M != 0 && T != 0 && N != 0)
{
memset(TM, 0, sizeof(TM));
for (int i = 0; i < T; ++i)
for (int j = 0; j < M; ++j)
scanf("%lf", &TM[i][j]);

double P1 = 1,P2 = 1;
for (int k = 0; k < T; ++k)
{
memset(DP, 0, sizeof(DP));
DP[0][0] = 1;
for (int i = 1; i <= M; ++i)
for (int j = 0; j <= M; ++j)
DP[i][j] = (j == 0)? DP[i-1][j] * (1 - TM[k][i - 1]):DP[i-1][j-1] * TM[k][i - 1] + DP[i-1][j] * (1 - TM[k][i - 1]);

P1 *= (1 - DP[M][0]);

double P = 0;
for (int i = 1; i < N; ++i) P += DP[M][i];

P2 *= P;
}
cout << fixed << showpoint << setprecision(3)<< P1 - P2 << endl;
};
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: