您的位置:首页 > 其它

zoj 2850

2009-10-03 18:13 267 查看
Beautiful Meadow

Time Limit: 1 Second Memory Limit: 32768 KB



Tom's Meadow

Tom has a meadow in his garden. He divides it into N * M squares. Initially all the squares were covered with grass. He mowed down the grass on some of the squares and thinks the meadow is beautiful if and only if

Not all squares are covered with grass.

No two mowed squares are adjacent.

Two squares are adjacent if they share an edge. Here comes the problem: Is Tom's meadow beautiful now?

Input

The input contains multiple test cases!

Each test case starts with a line containing two integers N, M (1 <= N, M <= 10) separated by a space. There follows the description of Tom's Meadow. There're N lines each consisting of M integers separated by a space. 0(zero) means the corresponding position of the meadow is mowed and 1(one) means the square is covered by grass.

A line with N = 0 and M = 0 signals the end of the input, which should not be processed

Output

One line for each test case.

Output "Yes" (without quotations) if the meadow is beautiful, otherwise "No"(without quotations).

Sample Input

2 2
1 0
0 1
2 2
1 1
0 0
2 3
1 1 1
1 1 1
0 0

Sample Output

Yes
No
No
//2850
#include <iostream>
using namespace std;

int main()
{
int m,n;
while(cin>>m>>n&&m!=0&&n!=0)
{
int **a = new int*[m];
for(int i = 0 ; i < m; i++)
{
a[i] = new int
;
for( int j =0 ; j < n; j++)
cin>>a[i][j];
}

int flag = 0;
int t = 0;
for( int ii = 0 ; ii < m ; ii++)
{
for ( int jj =0 ; jj < n; jj++)
{
if(a[ii][jj] == 0)
{
if(ii-1>=0&&a[ii-1][jj]==a[ii][jj])
flag++;
if(ii+1<m&&a[ii+1][jj]==a[ii][jj])
flag++;
if(jj+1<n&&a[ii][jj+1]==a[ii][jj])
flag++;
if(jj-1>=0&&a[ii][jj-1]==a[ii][jj])
flag++;
}
else
{
t++;
}
}
}
if( flag == 0&&t!=m*n)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: