您的位置:首页 > 编程语言 > PHP开发

PKU 2352 Stars

2009-09-07 16:31 211 查看
 
Description
Astronomers
often examine star maps where stars are represented by points on a
plane and each star has Cartesian coordinates. Let the level of a star
be an amount of the stars that are not higher and not to the right of
the given star. Astronomers want to know the distribution of the levels
of the stars.



For example, look at the map shown on the figure above. Level of
the star number 5 is equal to 3 (it's formed by three stars with a
numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4
are 1. At this map there are only one star of the level 0, two stars of
the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The
first line of the input file contains a number of stars N
(1<=N<=15000). The following N lines describe coordinates of
stars (two integers X and Y per line separated by a space,
0<=X,Y<=32000). There can be only one star at one point of the
plane. Stars are listed in ascending order of Y coordinate. Stars with
equal Y coordinates are listed in ascending order of X coordinate.

Output
The
output should contain N lines, one number per line. The first line
contains amount of stars of the level 0, the second does amount of
stars of the level 1 and so on, the last line contains amount of stars
of the level N-1.
Sample Input
5

1 1

5 1

7 1

3 3

5 5

Sample Output
1

2

1

1

//#include "stdafx.h"
//============================================================================
// Name        : acmcpp.cpp
// Author      : Yubo Chow
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <queue>
#include <math.h>
#include <algorithm>
#include <set>
#include <limits.h>
#include <float.h>
#include <bitset>
#include <cmath>
#include <vector>
#include <map>
#include <list>
#include <string.h>
using namespace std;

int n;
int x, y;

int tree[32000 * 4];
int ret[15000];

int search(int x, int p = 0, int left = 0, int right = 32000) {
tree[p]++;
if (left == right) {
return tree[p] - 1;
}
int middle = (left + right) >> 1;
if (middle >= x) {
return search(x, p * 2 + 1, left, middle);
} else {
return search(x, p * 2 + 2, middle + 1, right) + tree[p * 2 + 1];
}
}

int main() {
#ifndef ONLINE_JUDGE
freopen("case.txt", "r", stdin);
#endif

memset(tree, 0, sizeof tree);
memset(ret, 0, sizeof ret);
cin >> n;
for (int i = 0; i < n; ++i) {
scanf("%d%d", &x, &y);
ret[search(x)]++;
}

for (int i = 0; i < n; ++i) {
printf("%d/n", ret[i]);
}

return 0;
}


0
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息