您的位置:首页 > 大数据 > 人工智能

PKU 1325 Machine Schedule

2009-08-31 16:55 162 查看
Description
As we all
know, machine scheduling is a very classical problem in computer
science and has been studied for a very long history. Scheduling
problems differ widely in the nature of the constraints that must be
satisfied and the type of schedule desired. Here we consider a
2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working
modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine
B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the
beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of
the two machines in particular mode. For example, job 0 can either be
processed in machine A at mode_3 or in machine B at mode_4, job 1 can
either be processed in machine A at mode_2 or in machine B at mode_4,
and so on. Thus, for job i, the constraint can be represent as a triple
(i, x, y), which means it can be processed either in machine A at
mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the
machine's working mode from time to time, but unfortunately, the
machine's working mode can only be changed by restarting it manually.
By changing the sequence of the jobs and assigning each job to a
suitable machine, please write a program to minimize the times of
restarting machines.

Input
The
input file for this program consists of several configurations. The
first line of one configuration contains three positive integers: n, m
(n, m < 100) and k (k < 1000). The following k lines give the
constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Input
5 5 10

0 1 1

1 1 2

2 1 3

3 1 4

4 2 1

5 2 2

6 2 3

7 2 4

8 3 3

9 4 3

0

Sample Output
[code]3

因为初始mode是0,所以二分匹配从1开始。

//#include "stdafx.h"
//============================================================================
// Name        : acmcpp.cpp
// Author      : Yubo Chow
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <queue>
#include <math.h>
#include <algorithm>
#include <set>
#include <limits.h>
#include <float.h>
#include <bitset>
#include <cmath>
#include <vector>
#include <map>
#include <list>
#include <string.h>
using namespace std;

int n, m, k;

bool g[1000][1000];
bitset<1000> tmatch;
int match[1000];

bool to_match(int i) {
for (int j = 1; j < m; ++j) {
if (!tmatch.test(j) && g[i][j]) {
tmatch.set(j);
if (!match[j] || to_match(match[j])) {
match[j] = i;
return true;
}
}
}
return false;
}

int main() {
#ifndef ONLINE_JUDGE
freopen("case.txt", "r", stdin);
#endif

while (cin >> n >> m >> k && n) {
memset(g, 0, sizeof g);
memset(match, 0, sizeof match);

for (int i = 0; i < k; ++i) {
int x, a, b;
scanf("%d%d%d", &x, &a, &b);
g[a][b] = 1;
}
int ret = 0;
for (int i = 1; i < n; ++i) {
tmatch.reset();
if (to_match(i)) {
ret++;
}
}
cout << ret << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息