您的位置:首页 > 其它

FOJ--1635--Commandos--解题报告

2009-08-02 08:23 239 查看
A group of commandos were assigned a critical task. They are to destroy an enemy head quarter. The enemy head quarter consists of several buildings and the buildings are connected by roads. The commandos must visit each building and place a bomb at the base of each building. They start their mission at the base of a particular building and from there they disseminate to reach each building. The commandos must use the available roads to travel between buildings. Any of them can visit one building after another, but they must all gather at a common place when their task in done. In this problem, you will be given the description of different enemy headquarters. Your job is to determine the minimum time needed to complete the mission. Each commando takes exactly one unit of time to move between buildings. You may assume that the time required to place a bomb is negligible. Each commando can carry unlimited number of bombs and there is an unlimited supply of commando troops for the mission.

Input

The first line of input contains a number T<50, where T denotes the number of test cases. Each case describes one head quarter scenario. The first line of each case starts with a positive integer N≤100, where N denotes the number of buildings in the head quarter. The next line contains a positive integer R, where R is the number of roads connecting two buildings. Each of the next R lines contain two distinct numbers, 0 ≤ u,v < N, this means there is a road connecting building u to building v. The buildings are numbered from 0 to N-1. The last line of each case contains two integers 0 ≤ s,d < N. Where s denotes the building from where the mission starts and d denotes the building where they must meet. You may assume that two buildings will be directly connected by at most one road. The input will be such that, it will be possible to go from any building to another by using one or more roads.

Output

For each case of input, there will be one line of output. It will contain the case number followed by the minimum time required to complete the mission. Look at the sample output for exact formatting.

Sample Input

2
4
3
0 1
2 1
1 3
0 3
2
1
0 1
1 0

Sample Output

Case 1: 4
Case 2: 1


分析:使用Floyd算法,先将各点之间的最短路径算出存在数组中,在找起点到终点的最大时间,就是最短的时间了

代码如下:

#include <stdio.h>
#include <string.h>
int main()
{
int n,m,l,i,j,x,y,p,q,k;
int a[100][100];
scanf("%d",&n);
for(j=1;j<=n;j++)
{
for(k=0;k<100;k++)   // 初始化:本身赋值0,无法到达赋值大值
{
for(p=0;p<100;p++)
{
if(p==k)
a[k][p]=0;
else
a[k][p]=9999;
}
}
scanf("%d%d",&m,&l);
for(i=0;i<l;i++)
{
scanf("%d%d",&x,&y);
a[x][y]=1;
a[y][x]=1;
}
for(k=0;k<m;k++)   //Floyd算法 求最短路径
{
for(p=0;p<m;p++)
for(q=0;q<m;q++)
{
if(a[p][q]>a[p][k]+a[k][q])
{
a[p][q]=a[p][k]+a[k][q];
}
}
}
scanf("%d%d",&x,&y);
int max=0;
for(i=0;i<m;i++)   //找时间最长的,就是所求的最短时间
{
if(a[x][i]+a[i][y]>max)
max=a[x][i]+a[i][y];
}
printf("Case %d: %d/n",j,max);
}
return 0;
}
[/code]
[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: