您的位置:首页 > 其它

FOJ--1629--Above Average--解题报告

2009-07-27 00:09 323 查看
http://acm.fzu.edu.cn/problem.php?pid=1629
It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class. For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.

Sample Input
5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91

Sample Output
40.000%
57.143%
33.333%
66.667%
55.556%

分析:就是求平均值,然后求出大于平均值的数占全部数的百分比

代码如下:
#include <stdio.h>
int main()
{
int n,m,i,num;
double sum,ave,per;
int score[1000];
while (scanf("%d",&n)!=EOF)
{
while (n--)
{
sum=0;
num=0;
scanf("%d",&m);
for(i=0;i<m;i++)
{
scanf("%d",&score[i]);
sum+=score[i];
}
ave=sum/m;
for(i=0;i<m;i++)
if(score[i]>ave)
num++;
per=(double)num/m*100;
printf("%.03lf%c/n",per,'%');
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: