您的位置:首页 > 其它

ZOJ 1711 Sum It Up

2009-05-21 12:42 295 查看
/*
Sum It Up

--------------------------------------------------------------------------------

Time Limit: 1 Second Memory Limit: 32768 KB

--------------------------------------------------------------------------------
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input file will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

标准深搜, 通过记录上一次的叶节点来不输出相同解
*/
#include <iostream>
using namespace std;

int t,n;
int num[13];
int x[13];
int cn,l,flag,j;
void dfs(int i)
{
if(i>n)
{
if(cn==t)
{
flag=1;
for(int k=0;k<j;++k)
{
if(k)
cout<<"+";
cout<<x[k];
}

cout<<endl;
}
return;
}

if(cn+num[i]<=t && num[i]!=l) //l 用于记录上一个叶子结点, 若此次结点值与上一个叶子结点相同,则是相同解, 忽略掉
{
x[j++]=num[i];
cn+=num[i];

dfs(i+1);
cn-=num[i];
x[j--]=0;
}
l=num[i];
dfs(i+1);
}

int main()
{
while(cin>>t>>n && t!=0 && n!=0)
{
cn=0;l=0; flag=0;j=0;
for(int i=1;i<=n;++i)
cin>>num[i];
memset(x,0,sizeof(x));
cout<<"Sums of "<<t<<":"<<endl;
dfs(1);
if(flag==0)
cout<<"NONE"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: